Ознакомьтесь с нашей политикой обработки персональных данных
Регистрация

Linux [Mint|Ubuntu|Debian|Arch|Suse|Alt]


Наша цель - сделать Unix* системы ближе и понятнее.На сегодняшний день, существует большое количество Unix-подобных операционных систем.Благодаря фонду свободного ПО подобные системы стали доступны всем желающим.Благодаря таким разработкам как Linux, GNU, BSD, etc. мы можем без труда подобрать удобную для себя платформу, будь то GNU/Linux или же BSD дистрибутив.Но остается последний и самый важный вопрос.Вопрос, который может возникнуть абсолютно у любого пользователя, вне зависимости от его квалификации:"Что все же выбрать из всего множества СПО под конкретную задачу?".
Наше сообщество призвано помочь принять это не легкое решение,и решить попутно вопросы, возникшие в процессе использования того или иного ПО.Мы ценим каждого участника сообщества.Отношения строятся на базе свободы, равенства, дружбы и понимания.Мы стремимся стать лучшим сообществом по Unix-подобным системам,и внести вклад в развитие сетевых взаимоотношений.



Счетчик посещений Counter.CO.KZ - бесплатный счетчик на любой вкус!
↓ ↑ ⇑
20:51 

Заземление и компоненты ПК

Привет. Если я прикоснулся к пластиковой части видеокарты напрямую без заземляющего браслета в работающем состоянии, но она продолжает работать, то мне стоит снять статистический ток с неё, или когда я выключаю компьютер он сам куда-то сходит? И если я надеваю антистатистический браслет, то к какой именно части корпуса мне стоит его крепить ключом-крокодилом или куда вообще, если я нахожусь в квартире? Как вообще обезопасить компьютер, если я так делал не один раз?


P.S Да, все розетки к подключенному ПК идут с заземлением.









 







20:49 

Человека, имеющего большой опыт в разработке плагинов WP

Добрый день,

требуется доделать совсем небольшой плагин, интересует live coding т.е именно что бы я смог объяснить и самое главное сам понять свои ошибки.


О плагине: Плагин должен генерировать каждые N минут кастомный sitemap-имяраздела.xml только для одного раздела сайта. Требуется создать хук и далее


Ищу человека который имет значительно больший опыт в разработке под wp, платить смогу 1000р в час(Увы больше нет.)









 , ,







20:46 

Onboard смена языка не работает

Система Debian 10, рабочая среда KDE. Имею английскую раскладку клавиатуры на ноутбуке, поэтому поставил себе Onboard, как единственный удобный вариант о котором знаю. При наборе текста, после нажатия на символ, язык возвращается на стандартный (английский). С чем это может быть связано и как исправить?









 , ,







19:44 

Vim 8.2

Состоялся релиз текстового редактора Vim версии 8.2. Одной из основных особенностей данного релиза является долгожданная поддержка всплывающих окон (в том числе и для плагинов).

В списке других нововведений:

  • Словари с возможностью использовать буквенные ключи: let options = #{width: 30, height: 24}
  • Команда const, которая служит для объявления неизменяемых переменных, например: const TIMER_DELAY = 400.
  • Доступна возможность использовать блочный синтаксис для присвоения текста из нескольких линий переменным.
    let lines =<< trim END
    line one
    line two
    END

  • Возможность использовать цепочку вызовов функций по типу:
    mylist->filter(filterexpr)->map(mapexpr)->sort()->join()
  • Используется библиотека xdiff для улучшенного представления отличий в текстах.
  • Несколько изменений, улучшающих использование Vim под ОС семейства Windows: поддержка переводов для установочного файла, поддержка ConPTY.







 







19:25 

Wayland, Sway на AMD HD6290 будет ли работать?

Есть нетбук с AMD C-60 и HD6290. Хочу использовать его для открытия pdf, xlsx, работы в паре-тройке легковесных программ через wine.


В 2012-2014 бук тянул спокойно KDE, XFCE, Mate, Cinnamon (Gnome 3 подтормаживал), браузер нормально работал, по выходу ядра 3.11 и свежей на тот момент Mesa завелось аппаратное ускорение на Youtube через Adobe Flash.


А сейчас то ли я привык к более мощным компам, то ли что-то у него по железу стало деградирвать, но даже Windows 7 Starter на нём еле ворочается, Excel открывается по 2-3 минуты, прокрутка веб-страниц тормозит даже при одной вкладке в браузере, об онлайн-видео не в 360p можно забыть. И это всё под Windows, которая ещё и не хочет активироваться ключом с наклейки – видимо, надо ставить тот образ, что стоял на нём с завода.


В общем, вопрос – что на него поставить и как настроить, чтоб он работал максимально быстро в use-case из первого абзаца? Fedora с Gnome 3 он явно не потянет. Готов осиливать и пользоваться «хакерскими» (т.е. легко кастомизируемыми через редактирование конфигов или исходного кода) WM и программами.









 , , ,







18:48 

Не работает установка новых app и обновление Elementary OS

HELP guys and girlz.


Не устанавливается никакое приложение и соответственно не происходит никакое обновление.


И вот что пишет терминал при попытки установки любого приложения:


The following packages have unmet dependencies:
linux-image-generic : Depends: linux-image-4.15.0-72-generic but it is not going to be installed
linux-modules-extra-4.15.0-72-generic : Depends: linux-image-4.15.0-72-generic but it is not going to be installed or
linux-image-unsigned-4.15.0-72-generic but it is not going to be installed
E: Unmet dependencies. Try 'apt —fix-broken install' with no packages (or specify a solution).


После запуска предложенной команды, ответ следующий:


E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?


Файл lock-frontend имеется, но весит 0 байт и будто повреждён.


Пакета ядра linux-image-4.15.0-72-generic действительно нет, но и поставить я его уже не могу.. какой-то замкнутый круг.


И вот реакция системы на установку через AppCenter:
https://imgur.com/5okmJ9D


Куда копать и что делать? Ясного ответа в интернете сам не нашёл.


Стоит:


elementary OS 5.1 Hera
Built on Ubuntu 18.04.3 LTS
Linux 4.15.0-64-generic
GTK 3.22.30









 ,







18:17 

Обновление сломалось убунту

...
Ошб:6 dl.bintray.com/resin-io/debian stable Release
404 Not Found [IP: 3.124.133.231 443]
Чтение списков пакетов… Готово
E: Репозиторий «dl.bintray.com/resin-io/debian stable Release» не содержит файла Release.
N: Обновление из этого репозитория нельзя выполнить безопасным способом, поэтому по умолчанию он отключён.
N: Информацию о создании репозитория и настройках пользователя смотрите в справочной странице apt-secure(8).










 







17:36 

Посоветуйте портативную ОС

Всем привет! Нужна портативная версия ОС на usb-флешке, чтобы в любом месте и в любое время я мог иметь доступ к своей работе. Пробовал Tails, но идет очень туго, так как раньше никогда не пользовался Linux. Решил не парить свой мозг и попробовать что-то более упрощенное. Что можете посоветовать?









 , ,







15:55 

Как работать с форматом Visio на Linux?

Подскажите, пожалуйста, какие программы могут работать с файлами формата *.vsd *.vsdx (формат файлов Visio)
Интересуют в первую очередь программы под Linux.


P.S. Visio через wine не пошла, да и работать под wine как-то …… :/









 ,







15:40 

Gnome nautilus горячие клавиши

Ubuntu 18.04. Возможно в nautilus обозначит горячие клавиши на создание файла?









 







15:05 

Нытьё о веб-программировании, веб-программистах и веб-стандартах

У меня тут жизнь пошла под откос и чтобы не голодать взялся я небольшой муниципальной организации сайт писать.
Сам я прикладной программист и до этого с вебом изнутри особо не сталкивался.
Пишу в общем сайтец, наворачиваю всякую функциональность, всё довольно неплохо. Но в погоне за сутью я полностью забил на внешний вид (особенно в той части сейта, где нет пользователей и куда заходят лишь сотрудники). И вот появилось немного свободного времени и захотелось мне навести красоту. А то вход в админку представлял из себя форму с двумя input-ами и кнопкой. Никто не жаловался, но эстетикой сайт не испортишь.
Я не дизайнер. Скорее даже наоборот :)
Поэтому полез в интернет с запросом вроде «форма логина скачать».
Нашёл. Минималистичную такую форму логина. Даже вполне мило выглядящую. Самая скромная весила 15 МиБ. С полуметром CSS-ок, парой метров ЯваСкрипта и остальное — шрифты.
Подохренел я от такого счастья.
Написал сам. Вместе с логикой по собственно логину, а также тривиальной обработкой ошибок получилось 1.5КиБ.

Мораль? Веб — дерьмище.








 , ,







15:00 

можно ли сконфигурировать разные upstream для веток по регекспу или префиксу?

У локального git-репозитория есть два разных remote: допустим origin и custom


Хочется чтобы при создании локальной ветки трекинг настраивался автоматически, по префиксу или по регэкспу в названии ветки, и для ветки custom-* автоматически в качестве upstream устанавливался custom.


Есть ли какая-то возможность настроить это в конфиге, или без скриптов и bash-алиасов не обойтись?









 







14:56 

Нужна утилита для получения транскрипции.

Пытался написать скрипт для быстрой генерации карточек для anki. Как выяснилось утилита translate-shell не вполне подходит для этого ибо отображает какую то неведомую не IPA транскрипцию (её зачем то пользует Google Translate). Искал разные оффлайн словари, но так и не нашёл никакого консольного интерфейса для взаимодействия со словарями. Есть что на примете?









 







14:31 

Как установить xfce4-panel-profiles в Linux Mint 19.3 Tricia?

При установке из архива xfce4-panel-profiles-1.0.9.tar.bz2 возникает ошибка 127









 







14:20 

Установка драйвера на QCA6174 Debian 10

Имею Acer Aspire V15 Nitro (VN7-591G-58NM), на котором стоит Debian 10. Пытаюсь решить ошибки c WiFi QCA6174

sudo dmesg  | grep -i ath10k_pci
[ 4.971817] ath10k_pci 0000:07:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[ 5.288411] ath10k_pci 0000:07:00.0: firmware: failed to load ath10k/pre-cal-pci-0000:07:00.0.bin (-2)
[ 5.288441] ath10k_pci 0000:07:00.0: firmware: failed to load ath10k/cal-pci-0000:07:00.0.bin (-2)
[ 5.288757] ath10k_pci 0000:07:00.0: firmware: failed to load ath10k/QCA6174/hw2.1/firmware-6.bin (-2)
[ 5.290228] ath10k_pci 0000:07:00.0: firmware: direct-loading firmware ath10k/QCA6174/hw2.1/firmware-5.bin
[ 5.290239] ath10k_pci 0000:07:00.0: qca6174 hw2.1 target 0x05010000 chip_id 0x003405ff sub 105b:e08e
[ 5.290242] ath10k_pci 0000:07:00.0: kconfig debug 0 debugfs 0 tracing 0 dfs 0 testmode 0
[ 5.290751] ath10k_pci 0000:07:00.0: firmware ver SW_RM.1.1.1-00157-QCARMSWPZ-1 api 5 features ignore-otp,no-4addr-pad crc32 10bf8e08
[ 5.360775] ath10k_pci 0000:07:00.0: firmware: direct-loading firmware ath10k/QCA6174/hw2.1/board-2.bin
[ 5.361101] ath10k_pci 0000:07:00.0: board_file api 2 bmi_id N/A crc32 ae2e275a
[ 6.798689] ath10k_pci 0000:07:00.0: htt-ver 3.1 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[ 7.102184] ath10k_pci 0000:07:00.0 wlp7s0: renamed from wlan0

Ошибки запуска

дек 14 10:54:29 pups kernel: ACPI Error: No handler for Region [RAM_] (00000000b6871056) [EmbeddedControl] (20180810/evregion-132)
дек 14 10:54:29 pups kernel: ACPI Error: Region EmbeddedControl (ID=3) has no handler (20180810/exfldio-265)
дек 14 10:54:29 pups kernel: ACPI Error: Method parse/execution failed \_SB.PCI0.LPCB.EC0._REG, AE_NOT_EXIST (20180810/psparse-516)
дек 14 10:54:29 pups kernel: ACPI Error: No handler for Region [RAM_] (00000000b6871056) [EmbeddedControl] (20180810/evregion-132)
дек 14 10:54:29 pups kernel: ACPI Error: Region EmbeddedControl (ID=3) has no handler (20180810/exfldio-265)
дек 14 10:54:29 pups kernel: ACPI Error: Method parse/execution failed \_SB.PCI0.LPCB.EC0._REG, AE_NOT_EXIST (20180810/psparse-516)
дек 14 10:54:29 pups kernel: ACPI BIOS Error (bug): Could not resolve [\_SB.PCI0.GFX0.DD02._BCL], AE_NOT_FOUND (20180810/psargs-330)
дек 14 10:54:29 pups kernel: ACPI Error: Method parse/execution failed \_SB.PCI0.PEG0.PEGP.DD02._BCL, AE_NOT_FOUND (20180810/psparse-516)
дек 14 10:54:29 pups kernel: ath10k_pci 0000:07:00.0: firmware: failed to load ath10k/pre-cal-pci-0000:07:00.0.bin (-2)
дек 14 10:54:29 pups kernel: firmware_class: See wiki.debian.org/Firmware for information about missing firmware
дек 14 10:54:29 pups kernel: ath10k_pci 0000:07:00.0: firmware: failed to load ath10k/cal-pci-0000:07:00.0.bin (-2)
дек 14 10:54:29 pups kernel: ath10k_pci 0000:07:00.0: firmware: failed to load ath10k/QCA6174/hw2.1/firmware-6.bin (-2)

firmware-atheros установлен. Что интересно, linux-firmware и firmware-atheros не содержат в папке hw 2.1 файл firmware-6. cal-pci-0000:07:00.0 вообще нет.








 , ,







13:52 

Pdf text reflow на Android

Вассап лор. Разыскивается читалка pdf на андроид умеющая в text reflow. Кто не понял это что бы pdf читался на мобильном экране, переформатирование короче. Из тех что нашёл, все старые и нормально работать на 9 андроиде не хотют. Неужели читать перестали?


Зы:ниннада в /mobile пжалста, там мало людей









 , ,







13:49 

Моя рабочая машинка







Вот наконец-то купил себе новый ноут. Долго выбирал из всевозможных вариантов, остановился на Lenovo ideapad 720S-13ARR с процессором AMD Ryzen 7 2700U, NVMe, Type-C и прочими прелястями жизни.


На скриншоте - powerlevel10k, улучшенная и ускоренная версия powerlevel9k, лучшего powerline-шелла для zfs, ну и несколько интересных плагинов которые позволяют разукрасить консоль подобно fish.


Справа выводятся модули:



  • текущий контекст и неймспейс Kubernetes

  • текущая ветка git


В качестве рутовой файловой системы - btrfs. Каждый вызов pacman содаёт снапшот и в любой момент можно в него загрузиться прямо из меню grub.


Ноут использую как дома, так и на работе. На работе подключаю его через Type-C док-станцию с двумя мониторами через displaylink, очень удобно. Очень порадовало наличие аппаратного шифрования NVMe-диска и возможность зарядки от пауэрбанка, а процессор AMD достаточно производителен и не подвержен уязвимостям Meltdown и Spectre.


Подробности:























>>> Просмотр
(1920x1080,
1862 Kb
)










 , ,







13:40 

Debian 10. Не открывается терминал

При смене локали на английский язык не открывается терминал. Крутится значок загрузки и пропадает.
что делать?
Оболочка Gnome. Утилита->Терминал









 ,







12:52 

ModuleNotFoundError: No module named '_sqlite3'

Привет.


Вчера установил Django и при запуске локального сервера «python manage.py runserver» выдает ошибку:


(vevn) dizinnes@dizinnes-Aspire-A315-41G:~/PycharmProjects/qwe/mysite$ python manage.py runserver
Watching for file changes with StatReloader
Exception in thread django-main-thread:
Traceback (most recent call last):
File "/usr/local/lib/python3.8/threading.py", line 932, in _bootstrap_inner
self.run()
File "/usr/local/lib/python3.8/threading.py", line 870, in run
self._target(*self._args, **self._kwargs)
File "/home/dizinnes/PycharmProjects/qwe/vevn/lib/python3.8/site-packages/django/utils/autoreload.py", line 53, in wrapper
fn(*args, **kwargs)
File "/home/dizinnes/PycharmProjects/qwe/vevn/lib/python3.8/site-packages/django/core/management/commands/runserver.py", line 109, in inner_run
autoreload.raise_last_exception()
File "/home/dizinnes/PycharmProjects/qwe/vevn/lib/python3.8/site-packages/django/utils/autoreload.py", line 76, in raise_last_exception
raise _exception[1]
File "/home/dizinnes/PycharmProjects/qwe/vevn/lib/python3.8/site-packages/django/core/management/__init__.py", line 357, in execute
autoreload.check_errors(django.setup)()
File "/home/dizinnes/PycharmProjects/qwe/vevn/lib/python3.8/site-packages/django/utils/autoreload.py", line 53, in wrapper
fn(*args, **kwargs)
File "/home/dizinnes/PycharmProjects/qwe/vevn/lib/python3.8/site-packages/django/__init__.py", line 24, in setup
apps.populate(settings.INSTALLED_APPS)
File "/home/dizinnes/PycharmProjects/qwe/vevn/lib/python3.8/site-packages/django/apps/registry.py", line 114, in populate
app_config.import_models()
File "/home/dizinnes/PycharmProjects/qwe/vevn/lib/python3.8/site-packages/django/apps/config.py", line 211, in import_models
self.models_module = import_module(models_module_name)
File "/usr/local/lib/python3.8/importlib/__init__.py", line 127, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File "<frozen importlib._bootstrap>", line 1014, in _gcd_import
File "<frozen importlib._bootstrap>", line 991, in _find_and_load
File "<frozen importlib._bootstrap>", line 975, in _find_and_load_unlocked
File "<frozen importlib._bootstrap>", line 671, in _load_unlocked
File "<frozen importlib._bootstrap_external>", line 783, in exec_module
File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
File "/home/dizinnes/PycharmProjects/qwe/vevn/lib/python3.8/site-packages/django/contrib/auth/models.py", line 2, in <module>
from django.contrib.auth.base_user import AbstractBaseUser, BaseUserManager
File "/home/dizinnes/PycharmProjects/qwe/vevn/lib/python3.8/site-packages/django/contrib/auth/base_user.py", line 47, in <module>
class AbstractBaseUser(models.Model):
File "/home/dizinnes/PycharmProjects/qwe/vevn/lib/python3.8/site-packages/django/db/models/base.py", line 121, in __new__
new_class.add_to_class('_meta', Options(meta, app_label))
File "/home/dizinnes/PycharmProjects/qwe/vevn/lib/python3.8/site-packages/django/db/models/base.py", line 325, in add_to_class
value.contribute_to_class(cls, name)
File "/home/dizinnes/PycharmProjects/qwe/vevn/lib/python3.8/site-packages/django/db/models/options.py", line 208, in contribute_to_class
self.db_table = truncate_name(self.db_table, connection.ops.max_name_length())
File "/home/dizinnes/PycharmProjects/qwe/vevn/lib/python3.8/site-packages/django/db/__init__.py", line 28, in __getattr__
return getattr(connections[DEFAULT_DB_ALIAS], item)
File "/home/dizinnes/PycharmProjects/qwe/vevn/lib/python3.8/site-packages/django/db/utils.py", line 207, in __getitem__
backend = load_backend(db['ENGINE'])
File "/home/dizinnes/PycharmProjects/qwe/vevn/lib/python3.8/site-packages/django/db/utils.py", line 111, in load_backend
return import_module('%s.base' % backend_name)
File "/usr/local/lib/python3.8/importlib/__init__.py", line 127, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File "/home/dizinnes/PycharmProjects/qwe/vevn/lib/python3.8/site-packages/django/db/backends/sqlite3/base.py", line 14, in <module>
from sqlite3 import dbapi2 as Database
File "/usr/local/lib/python3.8/sqlite3/__init__.py", line 23, in <module>
from sqlite3.dbapi2 import *
File "/usr/local/lib/python3.8/sqlite3/dbapi2.py", line 27, in <module>
from _sqlite3 import *
ModuleNotFoundError: No module named '_sqlite3'


Находил ответы: https://stackoverflow.com/questions/1210664/no-module-named-sqlite3 , ну они не помогают


Вот список pip list virtualenv:


(vevn) dizinnes@dizinnes-Aspire-A315-41G:~/PycharmProjects/qwe/mysite$ pip list
Package Version
---------- -------
antiorm 1.2.1
asgiref 3.2.3
db 0.1.1
db-sqlite3 0.0.1
Django 3.0
pip 19.3.1
pytz 2019.3
setuptools 41.2.0
sqlparse 0.3.0


OS:
Ubuntu 19.04









 ,







12:41 

IBM POWER 7 + server с 64 ядрами 4.2Ghz и 256 GB RAM

Думаю кому-то может это показаться интересным.
Аукцион начинается с 1 бакса и без резервной цены


https://www.ebay.com/itm/324011902590









 ,







E-mail: info@diary.ru
Rambler's Top100